FTPSync 2.8f changed requirements

Starting with FTPSync 2.8f, FTPSync requires Microsoft .NET Framework. This is not an issue with users running Windows Vista, Windows 7 or Windows Server 2008, as those systems come with .NET preinstalled. Most Windows XP or Windows Server 2003 systems also have .NET installed, as many newer applications require it.

If your computer does not have .NET installed, you will have to install it to run FTPSync 2.8f or later. The minimum required version is 2.0, although it is recommended to install the latest version available for your operating system (at the time of this post, version 4.0 is available). Download at:

In addition, FTPSync 2.8f comes with two additional DLLs, FTPSync.FS.dll and FTPSync.CS.dll. When upgrading FTPSync on your computers, make sure to copy those two DLLs as well, not only FTPSync.exe. Without those DLLs, FTPSync will report fatal error: File or assembly name FTPSync.FS, or one of its dependencies, was not found.